[webkit-reviews] review granted: [Bug 115898] Begin making SecurityOrigin immutable : [Attachment 201334] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri May 10 04:58:08 PDT 2013


Andreas Kling <akling at apple.com> has granted Anders Carlsson
<andersca at apple.com>'s request for review:
Bug 115898: Begin making SecurityOrigin immutable
https://bugs.webkit.org/show_bug.cgi?id=115898

Attachment 201334: Patch
https://bugs.webkit.org/attachment.cgi?id=201334&action=review

------- Additional Comments from Andreas Kling <akling at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=201334&action=review


r=me with some fixing!

> Source/WebCore/page/SecurityOrigin.cpp:219
> +    return adoptRef(new SecurityOrigin(m_protocol, m_host, domain,
m_filePath, m_port, m_isUnique, m_universalAccess, m_domainWasSetInDOM,
m_canLoadLocalResources, m_storageBlockingPolicy, m_enforceFilePathSeparation,
m_needsDatabaseIdentifierQuirkForFiles));

You're just passing m_domainWasSetInDOM again here, that argument should be
true.

> Source/WebCore/page/SecurityOrigin.h:80
> -    void setDomainFromDOM(const String& newDomain);
> +    PassRefPtr<SecurityOrigin> securityOriginWithDomainSetFromDOM(const
String& newDomain) const;

I'd call this securityOriginWithDomainSetFromDOM().

> Source/WebCore/page/SecurityOrigin.h:140
> -    void grantUniversalAccess();
> +    PassRefPtr<SecurityOrigin> securityOriginWithUniversalAccessGranted()
const;

I'd call this copyWithUniversalAccessGranted().


More information about the webkit-reviews mailing list