[webkit-reviews] review denied: [Bug 109659] Coordinated Graphics : Prevent code duplication of CoordinatedSurface : [Attachment 188005] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Mar 15 03:57:03 PDT 2013


Noam Rosenthal <noam at webkit.org> has denied Jae Hyun Park
<jae.park at company100.net>'s request for review:
Bug 109659: Coordinated Graphics : Prevent code duplication of
CoordinatedSurface
https://bugs.webkit.org/show_bug.cgi?id=109659

Attachment 188005: Patch
https://bugs.webkit.org/attachment.cgi?id=188005&action=review

------- Additional Comments from Noam Rosenthal <noam at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=188005&action=review


> Source/WebCore/ChangeLog:3
> +	   Coordinated Graphics : Prevent code duplication of
CoordinatedSurface

Coordinated Graphics:

> Source/WebCore/ChangeLog:10
> +	   This is patch moves CoordinatedSurface implementation that will be
shared
> +	   between WebKit1 CoordinatedSurface and WebCoordinatedSurface to
> +	   CoordinatedSurface so that it prevents code duplication.

Move some of the duplicated code to CoordinatedSurface.

> Source/WebCore/platform/graphics/texmap/coordinated/CoordinatedSurface.cpp:64

> +PassRefPtr<GraphicsSurface> CoordinatedSurface::createGraphicsSurface(const
IntSize& size, Flags flags)

createWithNewGraphicsSurface

> Source/WebCore/platform/graphics/texmap/coordinated/CoordinatedSurface.cpp:84

> +    RefPtr<BitmapTextureGL> textureGL = toBitmapTextureGL(texture);
> +    if (textureGL) {

You can't assume that textureMapper is GL based. You should only do this when
isBackedByOpenGL returns true.


More information about the webkit-reviews mailing list