[webkit-reviews] review granted: [Bug 111112] [chromium] Keydown event for 'shift+alt' returns win keycode instead of 'alt' : [Attachment 191592] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Mar 5 16:55:46 PST 2013


Tony Chang <tony at chromium.org> has granted chandra shekar vallala
<chandra.vallala at motorola.com>'s request for review:
Bug 111112: [chromium] Keydown event for 'shift+alt' returns win keycode
instead of 'alt'
https://bugs.webkit.org/show_bug.cgi?id=111112

Attachment 191592: patch
https://bugs.webkit.org/attachment.cgi?id=191592&action=review

------- Additional Comments from Tony Chang <tony at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=191592&action=review


Looks like you also need to rebase your patch to ToT.

> ManualTests/shift-alt-key-event.html:8
> +function myFunction(event)

Please use a better name than myFunction.  How about keyDown?

> ManualTests/shift-alt-key-event.html:14
> +    if(event.shiftKey == true && event.altKey == true && event.which == 18)
{

Nit: Put a space after if.

> ManualTests/shift-alt-key-event.html:16
> +    }else {

Nit: Space between } and else.

> ManualTests/shift-alt-key-event.html:19
> +    output.innerHTML=text;

Nit: Spaces around =.

> ManualTests/shift-alt-key-event.html:25
> +<p>Test for <a href="http://bugs.webkit.org/show_bug.cgi?id=?????">bug
?????</a>:

Please fill in the bug number or just remove this text.


More information about the webkit-reviews mailing list