[webkit-reviews] review granted: [Bug 118003] [Mac] Document URL is not updated by HSTS : [Attachment 205432] Patch v3 - Cleaner

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jun 25 18:47:20 PDT 2013


Alexey Proskuryakov <ap at webkit.org> has granted Brady Eidson
<beidson at apple.com>'s request for review:
Bug 118003: [Mac] Document URL is not updated by HSTS
https://bugs.webkit.org/show_bug.cgi?id=118003

Attachment 205432: Patch v3 - Cleaner
https://bugs.webkit.org/attachment.cgi?id=205432&action=review

------- Additional Comments from Alexey Proskuryakov <ap at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=205432&action=review


r=me. Please fix the build before landing.

> Source/WebCore/ChangeLog:15
> +	   * platform/network/mac/MacNetworkingExtras.h: Renamed from
Source/WebCore/platform/network/mac/WebCoreURLResponse.h.

This file name doesn't make me happy, it's so non-descriptive.

> Source/WebCore/platform/network/mac/MacNetworkingExtras.mm:328
> +#if __MAC_OS_X_VERSION_MIN_REQUIRED < 1090

We usually put "new" code first.

> Source/WebCore/platform/network/mac/MacNetworkingExtras.mm:334
> +    if (!redirectResponse && ![[[newRequest URL] scheme]
isEqualToString:[[[connection currentRequest] URL] scheme]]) {

I think that this would be easier to read with an early return:

if (redirectResponse)
    return redirectResponse;

if (long condition)
   ...


More information about the webkit-reviews mailing list