[webkit-reviews] review denied: [Bug 117637] Improve the number of style resolutions for NodeRenderingContext : [Attachment 204813] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jun 17 08:52:56 PDT 2013


Simon Fraser (smfr) <simon.fraser at apple.com> has denied Mihai Maerean
<mmaerean at adobe.com>'s request for review:
Bug 117637: Improve the number of style resolutions for NodeRenderingContext
https://bugs.webkit.org/show_bug.cgi?id=117637

Attachment 204813: patch
https://bugs.webkit.org/attachment.cgi?id=204813&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=204813&action=review


I find it very hard to follow this code, because both Element and
NodeRenderContext have moveToFlowThread* functions. I think some renaming first
would improve understanding of the code.

> Source/WebCore/dom/NodeRenderingContext.cpp:250
> +    bool haveTestedForMoveToFlowThread = false;
> +    for (const Element* parentElement = m_node->parentElement();
parentElement; parentElement = parentElement->parentElement()) {

You're adding a parent-chain walk here, which I assume will kick in for every
renderer creation, which is bad too.


More information about the webkit-reviews mailing list