[webkit-reviews] review granted: [Bug 117614] Function names on Object.prototype should be common identifiers : [Attachment 204649] Fixes the bug

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jun 13 17:40:34 PDT 2013


Darin Adler <darin at apple.com> has granted Ryosuke Niwa <rniwa at webkit.org>'s
request for review:
Bug 117614: Function names on Object.prototype should be common identifiers
https://bugs.webkit.org/show_bug.cgi?id=117614

Attachment 204649: Fixes the bug
https://bugs.webkit.org/attachment.cgi?id=204649&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=204649&action=review


> Source/JavaScriptCore/runtime/JSObject.h:1472
> +#define JSC_NATIVE_INTRINSIC_FUNCTION_IDENT(jsName, cppName, attributes,
length, intrinsic) \

We can do this without a second macro. We just need this inline function:

    inline Identifier makeIdentifier(ExecState* exec, const char* name)
    {
	return Identifier(exec, name);
    }

    inline Identifier makeIdentifier(ExecState*, const Identifier& identifier)
    {
	return identifier;
    }

Then change the existing macro to use this function instead of calling the
Identifier constructor directly. I’d love to not add a new macro. I also have
no idea why this is a macro instead of an inline function in the first place.


More information about the webkit-reviews mailing list