[webkit-reviews] review granted: [Bug 118355] Remove code duplication from StringImpl create()/reallocate() methods : [Attachment 205996] patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jul 3 08:27:15 PDT 2013


Anders Carlsson <andersca at apple.com> has granted Mikhail Pozdnyakov
<mikhail.pozdnyakov at intel.com>'s request for review:
Bug 118355: Remove code duplication from StringImpl create()/reallocate()
methods
https://bugs.webkit.org/show_bug.cgi?id=118355

Attachment 205996: patch
https://bugs.webkit.org/attachment.cgi?id=205996&action=review

------- Additional Comments from Anders Carlsson <andersca at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=205996&action=review


> Source/WTF/wtf/text/StringImpl.cpp:186
> +inline PassRefPtr<StringImpl> StringImpl::constructInternal(StringImpl*
arena, unsigned length)

I don't think arena is the right parameter name here. How about simply
"stringImpl"?

> Source/WTF/wtf/text/StringImpl.cpp:192
> +inline PassRefPtr<StringImpl>
StringImpl::constructInternal<LChar>(StringImpl* arena, unsigned length)

Ditto.


More information about the webkit-reviews mailing list