[webkit-reviews] review granted: [Bug 107640] The name ContainerNode::removeChildren and ContainerNde::removeAllChilren() is confusing : [Attachment 184392] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 23 22:23:38 PST 2013


Ryosuke Niwa <rniwa at webkit.org> has granted Hajime Morrita
<morrita at google.com>'s request for review:
Bug 107640: The name ContainerNode::removeChildren and
ContainerNde::removeAllChilren() is confusing
https://bugs.webkit.org/show_bug.cgi?id=107640

Attachment 184392: Patch
https://bugs.webkit.org/attachment.cgi?id=184392&action=review

------- Additional Comments from Ryosuke Niwa <rniwa at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=184392&action=review


> Source/WebCore/dom/ContainerNode.cpp:105
> -    oldParent->removeAllChildren();
> +    // removeDetachedChildren() cannot be used here sicne
takeAllChildrenFrom() violates its precondition
> +    // and does detach() its children after the removal.
> +    removeAllChildrenInContainer<Node, ContainerNode>(this);

Should we isolate put this in a separate patch so that we can merge it?


More information about the webkit-reviews mailing list