[webkit-reviews] review granted: [Bug 97375] IndexedDB: Remove IDBKey from WebKitIDL : [Attachment 184044] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Jan 22 16:17:27 PST 2013


Kentaro Hara <haraken at chromium.org> has granted Joshua Bell
<jsbell at chromium.org>'s request for review:
Bug 97375: IndexedDB: Remove IDBKey from WebKitIDL
https://bugs.webkit.org/show_bug.cgi?id=97375

Attachment 184044: Patch
https://bugs.webkit.org/attachment.cgi?id=184044&action=review

------- Additional Comments from Kentaro Hara <haraken at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=184044&action=review


>> Source/WebCore/bindings/js/IDBBindingUtilities.cpp:72
>> +static JSValue toJS(ExecState* exec, JSDOMGlobalObject* globalObject,
IDBKey* key)
> 
> Should I give this a more meaningful name, e.g. idbKeyToJSValue?

Sounds nicer. This method is not "toV8()" in our binding terminology (toV8() is
a method that wraps a DOM object).

>> Source/WebCore/bindings/v8/IDBBindingUtilities.cpp:42
>> +static v8::Handle<v8::Value> toV8(IDBKey* key, v8::Handle<v8::Object>
creationContext, v8::Isolate* isolate)
> 
> Should I give this a more meaningful name, e.g. idbKeyToV8Value?

Ditto. Let's rename.


More information about the webkit-reviews mailing list