[webkit-reviews] review denied: [Bug 107368] Add a helper function for getting strings from tokens (and make it 8-bit aware) : [Attachment 183614] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Jan 19 11:08:25 PST 2013


Adam Barth <abarth at webkit.org> has denied Eric Seidel <eric at webkit.org>'s
request for review:
Bug 107368: Add a helper function for getting strings from tokens (and make it
8-bit aware)
https://bugs.webkit.org/show_bug.cgi?id=107368

Attachment 183614: Patch
https://bugs.webkit.org/attachment.cgi?id=183614&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=183614&action=review


> Source/WebCore/html/parser/CompactHTMLToken.cpp:40
> +    if (!vector.size())
> +	   return emptyString();

There's no reason to do this.  Both String::make8BitFrom16BitSource and String
have special-case logic for the empty string.

> Source/WebCore/html/parser/CompactHTMLToken.cpp:41
> +    if (token.isAll8BitData())

This isn't correct for anything other than m_data.  We only track this flag for
the main data vector.  Perhaps we should make HTMLToken smarter and track this
flag for the other strings as well?


More information about the webkit-reviews mailing list