[webkit-reviews] review granted: [Bug 107193] Incorrect scrollable height during simplified layout : [Attachment 183312] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 17 16:42:54 PST 2013


Ojan Vafai <ojan at chromium.org> has granted Tony Chang <tony at chromium.org>'s
request for review:
Bug 107193: Incorrect scrollable height during simplified layout
https://bugs.webkit.org/show_bug.cgi?id=107193

Attachment 183312: Patch
https://bugs.webkit.org/attachment.cgi?id=183312&action=review

------- Additional Comments from Ojan Vafai <ojan at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=183312&action=review


> Source/WebCore/rendering/RenderBlock.cpp:2599
> +    LayoutUnit logicalScrollHeight = style()->isHorizontalWritingMode() ?
scrollHeight() : scrollWidth();

Should we add a helper function for this? I bet there are a bunch of places we
do this already.

> LayoutTests/fast/overflow/height-during-simplified-layout.html:17
> +shouldBe("document.getElementById('scrollable').scrollTop", "400");
> +shouldBe("document.getElementById('scrollable').scrollHeight", "600");

should we extend check-layout.js to support these?


More information about the webkit-reviews mailing list