[webkit-reviews] review denied: [Bug 106878] [EFL][Qt][WebGL] Avoid deleting an uncreated canvas. : [Attachment 182881] patchv5

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 17 14:28:25 PST 2013


Benjamin Poulain <benjamin at webkit.org> has denied Kalyan
<kalyan.kondapally at intel.com>'s request for review:
Bug 106878: [EFL][Qt][WebGL] Avoid deleting an uncreated canvas.
https://bugs.webkit.org/show_bug.cgi?id=106878

Attachment 182881: patchv5
https://bugs.webkit.org/attachment.cgi?id=182881&action=review

------- Additional Comments from Benjamin Poulain <benjamin at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=182881&action=review


You maintain m_canvasState even if USE(GRAPHICS_SURFACE) is false. You never
use the value in that case.
It looks like something is wrong with the #ifdef.

>
Source/WebKit2/WebProcess/WebPage/CoordinatedGraphics/CoordinatedGraphicsLayer.
cpp:334
> +	   }  else if ((m_canvasSize != platformLayer->platformLayerSize()) ||
(m_canvasToken != platformLayer->graphicsSurfaceToken()))
>	       // m_canvasToken can be different to
platformLayer->graphicsSurfaceToken(), even if m_canvasPlatformLayer equals
platformLayer.
> -	       m_canvasNeedsDestroy = true;
> -	       m_canvasNeedsCreate = true;
> -	   }
> +	       m_canvasState |= RecreateCanvas;

I would use a bracket here for clarity.


More information about the webkit-reviews mailing list