[webkit-reviews] review granted: [Bug 107140] Wire BackgroundHTMLParser to HTMLDocumentParser : [Attachment 183211] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 17 10:51:56 PST 2013


Adam Barth <abarth at webkit.org> has granted Tony Gentilcore
<tonyg at chromium.org>'s request for review:
Bug 107140: Wire BackgroundHTMLParser to HTMLDocumentParser
https://bugs.webkit.org/show_bug.cgi?id=107140

Attachment 183211: Patch
https://bugs.webkit.org/attachment.cgi?id=183211&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=183211&action=review


> Source/WebCore/html/parser/BackgroundHTMLParser.cpp:182
> -	       parser->didReceiveTokensFromBackgroundParser(delivery->tokens);
> +	       parser->feedTokens(delivery->tokens);

Can we keep the didReceiveTokensFromBackgroundParser name?  It's much more
descriptive than "feedTokens".

> Source/WebCore/html/parser/HTMLDocumentParser.h:44
> +class BackgroundHTMLParser;

I would probably put this forward declaration inside the ifdef.


More information about the webkit-reviews mailing list