[webkit-reviews] review granted: [Bug 106212] INPUT_MULTIPLE_FIELDS_UI: Step-up/-down of month/day field should respect min/max attributes : [Attachment 181631] Patch 2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Jan 7 21:50:15 PST 2013


Kent Tamura <tkent at chromium.org> has granted Kunihiko Sakamoto
<ksakamoto at chromium.org>'s request for review:
Bug 106212: INPUT_MULTIPLE_FIELDS_UI: Step-up/-down of month/day field should
respect min/max attributes
https://bugs.webkit.org/show_bug.cgi?id=106212

Attachment 181631: Patch 2
https://bugs.webkit.org/attachment.cgi?id=181631&action=review

------- Additional Comments from Kent Tamura <tkent at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=181631&action=review


> Source/WebCore/html/shadow/DateTimeEditElement.cpp:200
> +	       const Vector<String>& labels = fieldType ==
DateTimeFormat::FieldTypeMonth
> +		   ? (count == countForFullMonth
> +		       ? m_parameters.locale.monthLabels()
> +		       : m_parameters.locale.shortMonthLabels())
> +		   : (count == countForFullMonth
> +		       ? m_parameters.locale.standAloneMonthLabels()
> +		       : m_parameters.locale.shortStandAloneMonthLabels());

Nested	conditional operators are not good for code readability.
I recommend not merge count==countForFullMonth case and
count==countForNarrow/AbbreviatedMonth case.


More information about the webkit-reviews mailing list