[webkit-reviews] review granted: [Bug 105442] Querying transition-timing-function value on the computed style does not return keywords when it should. : [Attachment 181170] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Jan 3 10:33:02 PST 2013


Simon Fraser (smfr) <simon.fraser at apple.com> has granted Alexis Menard
(darktears) <alexis at webkit.org>'s request for review:
Bug 105442: Querying transition-timing-function value on the computed style
does not return keywords when it should.
https://bugs.webkit.org/show_bug.cgi?id=105442

Attachment 181170: Patch
https://bugs.webkit.org/attachment.cgi?id=181170&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=181170&action=review


> Source/WebCore/platform/animation/TimingFunction.h:81
> +    enum CubicBezierTimingFunctionType {

CubicBezierTimingFunctionType is a bit long-winded, esp. since this is in class
scope. I think this would be better as TimingFunctionPreset or something,
'Type' seems a bit too general.

> Source/WebCore/platform/animation/TimingFunction.h:122
> +	       return (m_cubicBezierTimingFunctionType != Custom &&
m_cubicBezierTimingFunctionType == ctf->m_cubicBezierTimingFunctionType) ||
(m_x1 == ctf->m_x1 && m_y1 == ctf->m_y1 && m_x2 == ctf->m_x2 && m_y2 ==
ctf->m_y2);

I think this would be clearer as two separate if tests.


More information about the webkit-reviews mailing list