[webkit-reviews] review granted: [Bug 90834] the body of seamless iframes should default to margin:0 : [Attachment 181035] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Jan 2 13:35:53 PST 2013


Antti Koivisto <koivisto at iki.fi> has granted Mike West <mkwst at chromium.org>'s
request for review:
Bug 90834: the body of seamless iframes should default to margin:0
https://bugs.webkit.org/show_bug.cgi?id=90834

Attachment 181035: Patch
https://bugs.webkit.org/attachment.cgi?id=181035&action=review

------- Additional Comments from Antti Koivisto <koivisto at iki.fi>
View in context: https://bugs.webkit.org/attachment.cgi?id=181035&action=review


r=me with the changes

> Source/WebCore/css/CSSSelector.cpp:169
> +#if ENABLE(IFRAME_SEAMLESS)
> +    case PseudoSeamlessDocument:
> +	   return SEAMLESS_DOCUMENT;
> +#endif

You should't need this (you are not using it anywhere). FULL_SCREEN_DOCUMENT
and pals look equally pointless, I think someone was just cargo-culting.

>> Source/WebCore/rendering/style/RenderStyleConstants.h:79
>>	FULL_SCREEN, FULL_SCREEN_DOCUMENT, FULL_SCREEN_ANCESTOR,
ANIMATING_FULL_SCREEN_TRANSITION,
>> +	SEAMLESS_DOCUMENT,
> 
> enum members should use InterCaps with an initial capital letter. 
[readability/enum_casing] [4]

It would be good to remove FULL_SCREEN ones too in another patch if they are as
useless as they look. I believe the confusingly named PseudoId enum is only
relevant for pseudo elements never pseudo classes.


More information about the webkit-reviews mailing list