[webkit-reviews] review canceled: [Bug 111061] Web Inspector: Adding existing key in DOMStorageItemsView leaves it inconsistent state : [Attachment 190687] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 28 03:05:51 PST 2013


Alexander Pavlov (apavlov) <apavlov at chromium.org> has canceled Vivek Galatage
<vivekg at webkit.org>'s request for review:
Bug 111061: Web Inspector: Adding existing key in DOMStorageItemsView leaves it
inconsistent state
https://bugs.webkit.org/show_bug.cgi?id=111061

Attachment 190687: Patch
https://bugs.webkit.org/attachment.cgi?id=190687&action=review

------- Additional Comments from Alexander Pavlov (apavlov)
<apavlov at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=190687&action=review


> Source/WebCore/inspector/front-end/DOMStorageItemsView.js:149
> +		   if (!keyFound) {

Please use early returns as extensively as possible. It improves the code
readability and makes it [a bit more] error-proof.

if (keyFound) {
    childNode.removeSelf();
    continue;
}

keyFound = true;
childNode.data.value = storageData.newValue;
childNode.refresh();
childNode.select();
childNode.reveal();
this.deleteButton.visible = true;


More information about the webkit-reviews mailing list