[webkit-reviews] review granted: [Bug 110601] [WebSocket] it is better to send User-Agent in opening handshakes : [Attachment 189766] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 22 09:23:47 PST 2013


Alexey Proskuryakov <ap at webkit.org> has granted Takashi Toyoshima
<toyoshim at chromium.org>'s request for review:
Bug 110601: [WebSocket] it is better to send User-Agent in opening handshakes
https://bugs.webkit.org/show_bug.cgi?id=110601

Attachment 189766: Patch
https://bugs.webkit.org/attachment.cgi?id=189766&action=review

------- Additional Comments from Alexey Proskuryakov <ap at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=189766&action=review


It's so horrible that we have to build the header twice, once for real and
second time for Web Inspector.

r=me

>
LayoutTests/http/tests/websocket/tests/hybi/useragent-in-openinghandshake.html:
1
> +<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML//EN">

Please use a regular HTML5 doctype:

<!DOCTYPE html>

>
LayoutTests/http/tests/websocket/tests/hybi/useragent-in-openinghandshake.html:
4
> +<script src="../../../../js-test-resources/js-test-pre.js"></script>

There is no need to build a document relative path, you can just use
'src="/js-test-resources/js-test-pre.js"'.

>
LayoutTests/http/tests/websocket/tests/hybi/useragent-in-openinghandshake.html:
27
> +    data = messageEvent.data;
> +    useragent = navigator.userAgent;
> +    shouldBe("data", "useragent");

Why not shouldBe("messageEvent.data", "navigator.userAgent")? That would make
test output a little clearer.

>
LayoutTests/http/tests/websocket/tests/hybi/useragent-in-openinghandshake.html:
40
> +<script src="../../../../js-test-resources/js-test-post.js"></script>

Ditto.


More information about the webkit-reviews mailing list