[webkit-reviews] review granted: [Bug 110208] Allow to retrieve the request data from abstract TextCheckingRequest to be accessible for WK2 : [Attachment 189298] hopefully fixes Mac build

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Feb 21 00:02:49 PST 2013


Hajime Morrita <morrita at google.com> has granted Grzegorz Czajkowski
<g.czajkowski at samsung.com>'s request for review:
Bug 110208: Allow to retrieve the request data from abstract
TextCheckingRequest to be accessible for WK2
https://bugs.webkit.org/show_bug.cgi?id=110208

Attachment 189298: hopefully fixes Mac build
https://bugs.webkit.org/attachment.cgi?id=189298&action=review

------- Additional Comments from Hajime Morrita <morrita at google.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=189298&action=review


Looks good overall. Could you polish a bit more?

> Source/WebCore/platform/text/TextChecking.h:91
> +const int unrequestedSequence = -1;

Could you move this into some classes or change the name a bit more verbose?
The name is too ambiguous to be WebCore global.

> Source/WebCore/platform/text/TextChecking.h:130
> +    const TextCheckingRequestData& data() const { return m_requestData; }

Looks like we no longer need to have m_requestData in this class. It can be
pushed down to SpellCheckRequest then data() can be pure virtual.


More information about the webkit-reviews mailing list