[webkit-reviews] review granted: [Bug 109278] Factor EventContext and introduces MouseOrFocusEventContext. : [Attachment 187277] Factor EventContext

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 8 09:23:59 PST 2013


Dimitri Glazkov (Google) <dglazkov at chromium.org> has granted Hayato Ito
<hayato at chromium.org>'s request for review:
Bug 109278: Factor EventContext and introduces MouseOrFocusEventContext.
https://bugs.webkit.org/show_bug.cgi?id=109278

Attachment 187277: Factor EventContext
https://bugs.webkit.org/attachment.cgi?id=187277&action=review

------- Additional Comments from Dimitri Glazkov (Google)
<dglazkov at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=187277&action=review


> Source/WebCore/dom/EventContext.h:61
> +typedef Vector<OwnPtr<EventContext>, 32> EventContextAncestors;

I am having trouble with this name. It seems more like an EventContextList. The
word "ancestors" is completely out of place here, though I personally
understand where it came from.

Another idea: we could use the DOM core terminology of "event path"
(http://dom.spec.whatwg.org/#dispatching-events) and instead of
EventContextAncestors and ensureEventContextAncestors (neither make good
sense), we just say "EventPath" and "ensureEventPath"?

>> Source/WebCore/dom/EventContext.h:65
>> +	MouseOrFocusEventContext(PassRefPtr<Node>, PassRefPtr<EventTarget>
currentTarget, PassRefPtr<EventTarget> target);
> 
> The parameter name "target" adds no information, so it should be removed. 
[readability/parameter_name] [5]

Style elf is mistaken! :)


More information about the webkit-reviews mailing list