[webkit-reviews] review granted: [Bug 109065] [v8] move persistent::new and ::dispose into same class : [Attachment 186875] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Feb 6 13:27:25 PST 2013


Adam Barth <abarth at webkit.org> has granted Dan Carney <dcarney at google.com>'s
request for review:
Bug 109065: [v8] move persistent::new and ::dispose into same class
https://bugs.webkit.org/show_bug.cgi?id=109065

Attachment 186875: Patch
https://bugs.webkit.org/attachment.cgi?id=186875&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=186875&action=review


Generally this patch looks fine.  I would prefer if the
associateObjectWithWrapper didn't have a raw boolean parameter though.	Either
an enum or a WrapperConfiguration seems better.

> Source/WebCore/bindings/v8/ScriptWrappable.h:47
> +	   if (!m_maskedWrapper.IsEmpty())
> +	       CRASH();

This part of the patch seems separable from the rest of this work.  Perhaps we
should make this change in a separate patch?

> Source/WebCore/bindings/v8/ScriptWrappable.h:79
>      v8::Persistent<v8::Object> m_maskedWrapper;

Aside from the masking, it seems like we could use a ScopedPersistent here.


More information about the webkit-reviews mailing list