[webkit-reviews] review denied: [Bug 108796] [WK2] Add WKErrorIsCancellation() to C API : [Attachment 186314] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Feb 4 09:06:20 PST 2013

Brady Eidson <beidson at apple.com> has denied Christophe Dumez
<dchris at gmail.com>'s request for review:
Bug 108796: [WK2] Add WKErrorIsCancellation() to C API

Attachment 186314: Patch

------- Additional Comments from Brady Eidson <beidson at apple.com>
Why don't we simply add a new error code to WKError.h?

The only thing that makes a cancellation error special is that it's error code
means "cancelled"
If we're adding a "WKErrorIsCancellation" API why not also add a
"WKErrorIsCannotLoadPlugIn" API?  Or a
"WKErrorFrameLoadInterruptedByPolicyChange" API?

Because that'd be crazy when clients can already compare an error's error code
to public API constants.

More information about the webkit-reviews mailing list