[webkit-reviews] review granted: [Bug 108088] [GStreamer] webkitwebsrc is exposed to application-side : [Attachment 186069] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Feb 1 09:52:36 PST 2013


Martin Robinson <mrobinson at webkit.org> has granted Philippe Normand
<pnormand at igalia.com>'s request for review:
Bug 108088: [GStreamer] webkitwebsrc is exposed to application-side
https://bugs.webkit.org/show_bug.cgi?id=108088

Attachment 186069: Patch
https://bugs.webkit.org/attachment.cgi?id=186069&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=186069&action=review


Thanks!

>
Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamer.cpp:343
> +    // Clean out everything after file:// url path.
> +    if (kurl.isLocalFile())
> +	   kurl.removeFragmentIdentifier();

Mind moving this into MediaPlayerPrivateGStreamer::setPlaybinURL?

> Source/WebCore/platform/graphics/gstreamer/MediaPlayerPrivateGStreamer.h:142
> +	       static KURL getPlaybinURL(const gchar* uri);

Probably should be called convertPlaybinURL since it's not a getter.

> Source/WebCore/platform/graphics/gstreamer/WebKitWebSourceGStreamer.cpp:596
> -    static gchar* protocols[] = {(gchar*) "http", (gchar*) "https", 0 };
> +    static gchar* protocols[] = {"webkit+http", "webkit+https", 0 };

I guess you need  const here?


More information about the webkit-reviews mailing list