[webkit-reviews] review granted: [Bug 125667] WK2: Add support for inline candidates on iOS : [Attachment 219135] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Dec 12 17:38:16 PST 2013


Benjamin Poulain <benjamin at webkit.org> has granted Enrica Casucci
<enrica at apple.com>'s request for review:
Bug 125667: WK2: Add support for inline candidates on iOS
https://bugs.webkit.org/show_bug.cgi?id=125667

Attachment 219135: Patch
https://bugs.webkit.org/attachment.cgi?id=219135&action=review

------- Additional Comments from Benjamin Poulain <benjamin at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=219135&action=review


> Source/WebKit2/UIProcess/WebPageProxy.h:1124
> +    void revealSelection();

What about renaming this to notifyRevealedSelection, and renaming
WebChromeClient::notifyRevealedSelectionByScrollingFrame to
WebChromeClient::notifyRevealedSelection()?

> Source/WebKit2/UIProcess/API/ios/WKInteractionView.mm:1413
> +    _markedText = (_page->editorState().hasComposition) ?
_page->editorState().markedText : String();

String() -> nil?

> Source/WebKit2/WebProcess/WebPage/WebPage.cpp:634
> +	       result.lastMarkedRect = compositionRects[compositionRects.size()
- 1].rect();

I think you can just use compositionRects.last().rect() here.


More information about the webkit-reviews mailing list