[webkit-reviews] review granted: [Bug 124720] Move CertificateInfo to WebCore : [Attachment 218793] proposed patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Dec 11 14:41:18 PST 2013


Darin Adler <darin at apple.com> has granted Csaba Osztrogonác <ossy at webkit.org>'s
request for review:
Bug 124720: Move CertificateInfo to WebCore
https://bugs.webkit.org/show_bug.cgi?id=124720

Attachment 218793: proposed patch
https://bugs.webkit.org/attachment.cgi?id=218793&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=218793&action=review


> Source/WebKit2/ChangeLog:38
> +	   * Shared/WebCoreArgumentCoders.cpp:
> +	   (CoreIPC::::encode):
> +	   (CoreIPC::::decode):
> +	   * Shared/WebCoreArgumentCoders.h:
> +	   * Shared/mac/WebCoreArgumentCodersMac.mm:
> +	   (CoreIPC::::encodePlatformData):
> +	   (CoreIPC::::decodePlatformData):
> +	   * Shared/soup/CertificateInfo.cpp:
> +	   * Shared/soup/WebCoreArgumentCodersSoup.cpp:
> +	   (CoreIPC::::encodePlatformData):
> +	   (CoreIPC::::decodePlatformData):

prepare-ChangeLog did not do a good job with these function names; normally I
fix those by hand when I see them in my patches’ change logs, but fixing the
script would be even better

> Source/WebKit2/WebProcess/WebProcess.h:56
> +#if !ENABLE(NETWORK_PROCESS) && USE(SOUP)
> +class CertificateInfo;
> +#endif

I don’t think we need to wrap this forward declaration in #if. Generally
speaking I think our style in the future should be to not waste time putting
forward declarations inside #if statements since they are much uglier like
that, and omitting them catches almost no errors that we wouldn’t catch other
ways.


More information about the webkit-reviews mailing list