[webkit-reviews] review granted: [Bug 125212] Make it possible to compare layout test results between various configurations of WebKit : [Attachment 218733] take 4 - take 3 was missing the added file...

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 9 11:14:01 PST 2013


Darin Adler <darin at apple.com> has granted Tim Horton <thorton at apple.com>'s
request for review:
Bug 125212: Make it possible to compare layout test results between various
configurations of WebKit
https://bugs.webkit.org/show_bug.cgi?id=125212

Attachment 218733: take 4 - take 3 was missing the added file...
https://bugs.webkit.org/attachment.cgi?id=218733&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=218733&action=review


> Tools/WebKitTestRunner/TestController.cpp:409
> +	   WKRetainPtr<WKStringRef> useRemoteLayerTreeKey =
adoptWK(WKStringCreateWithUTF8CString("RemoteLayerTree"));
> +	   WKRetainPtr<WKBooleanRef> useRemoteLayerTreeValue =
adoptWK(WKBooleanCreate(m_shouldUseRemoteLayerTree));
> +	   WKDictionaryAddItem(viewOptions.get(), useRemoteLayerTreeKey.get(),
useRemoteLayerTreeValue.get());

Helper functions could make code like this way easier to read.

    WKDictionaryAddItem(viewOptions.get(),
createWKString("removeLayerTree").get(),
createWKBoolean(m_shouldUseRemoteLayerTree).get());

I seem to recall making functions like that for WebKitTestRunner, but for some
reason I don’t see them.


More information about the webkit-reviews mailing list