[webkit-reviews] review denied: [Bug 125083] Fix !ENABLE(JAVASCRIPT_DEBUGGER) build : [Attachment 218192] Proposed patch - fixed style

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 2 11:32:14 PST 2013


Mark Lam <mark.lam at apple.com> has denied Peter Molnar
<pmolnar.u-szeged at partner.samsung.com>'s request for review:
Bug 125083: Fix !ENABLE(JAVASCRIPT_DEBUGGER) build
https://bugs.webkit.org/show_bug.cgi?id=125083

Attachment 218192: Proposed patch - fixed style
https://bugs.webkit.org/attachment.cgi?id=218192&action=review

------- Additional Comments from Mark Lam <mark.lam at apple.com>
We can avoid adding all these #if ENABLE(JAVASCRIPT_DEBUGGER) if we just add a
stub Debugger class in Debugger.h.  Something like this:

#if ENABLE(JAVASCRIPT_DEBUGGER)

class JS_EXPORT_PRIVATE Debugger {
    ...
};

#else // ENABLE(JAVASCRIPT_DEBUGGER)

class Debugger {
public:
    Debugger(bool = false) { }
    ... // More stubbed functions as needed.
};

#endif // ENABLE(JAVASCRIPT_DEBUGGER)

If done right, the performance and memory usage difference should be negligible
(if at all), and the code would be more readable due to not having #ifs
scattered in.

Can you please try that approach and submit another patch?


More information about the webkit-reviews mailing list