[webkit-reviews] review granted: [Bug 125052] Instead of watchpointing activation allocation, we should watchpoint entry into functions that have captured variables : [Attachment 218131] the patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Dec 2 10:57:49 PST 2013


Mark Hahnenberg <mhahnenberg at apple.com> has granted Filip Pizlo
<fpizlo at apple.com>'s request for review:
Bug 125052: Instead of watchpointing activation allocation, we should
watchpoint entry into functions that have captured variables
https://bugs.webkit.org/show_bug.cgi?id=125052

Attachment 218131: the patch
https://bugs.webkit.org/attachment.cgi?id=218131&action=review

------- Additional Comments from Mark Hahnenberg <mhahnenberg at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=218131&action=review


r=me with comments.

> Source/JavaScriptCore/dfg/DFGByteCodeParser.cpp:3012
>		       addToGraph(ActivationAllocationWatchpoint,
OpInfo(activation->symbolTable()));

Maybe rename ActivationAllocationWatchpoint to FunctionReentryWatchpoint?

> Source/JavaScriptCore/dfg/DFGWatchpointCollectionPhase.cpp:129
>	   case ActivationAllocationWatchpoint:

Ditto.


More information about the webkit-reviews mailing list