[webkit-reviews] review granted: [Bug 120505] Make JSValue bool conversion less dangerous : [Attachment 210130] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Aug 30 11:22:18 PDT 2013


Darin Adler <darin at apple.com> has granted Oliver Hunt <oliver at apple.com>'s
request for review:
Bug 120505: Make JSValue bool conversion less dangerous
https://bugs.webkit.org/show_bug.cgi?id=120505

Attachment 210130: Patch
https://bugs.webkit.org/attachment.cgi?id=210130&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=210130&action=review


> Source/JavaScriptCore/runtime/PropertyDescriptor.cpp:188
> +    if (other.m_value.isEmpty() != m_value.isEmpty()
> +	   || other.m_getter.isEmpty() != m_getter.isEmpty()
> +	   || other.m_setter.isEmpty() != m_setter.isEmpty())

Much easier to read! Still would like to see this merged onto a single line.

> Source/WTF/wtf/Compiler.h:226
> +#define UNLIKELY(x) __builtin_expect(static_cast<bool>(x), 0)

Is !! better than the cast? Do we want this cast even in the non-GCC side of
the macro?

> Source/WTF/wtf/Compiler.h:237
> +#define LIKELY(x) __builtin_expect(static_cast<bool>(x), 1)

Ditto.


More information about the webkit-reviews mailing list