[webkit-reviews] review granted: [Bug 119936] Fix some encapsulation issues of RuleSet : [Attachment 208979] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Aug 17 05:14:16 PDT 2013


Darin Adler <darin at apple.com> has granted Benjamin Poulain
<benjamin at webkit.org>'s request for review:
Bug 119936: Fix some encapsulation issues of RuleSet
https://bugs.webkit.org/show_bug.cgi?id=119936

Attachment 208979: Patch
https://bugs.webkit.org/attachment.cgi?id=208979&action=review

------- Additional Comments from Darin Adler <darin at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=208979&action=review


> Source/WebCore/css/RuleSet.h:111
> +	   RuleSetSelectorPair(const RuleSetSelectorPair& rs) :
selector(rs.selector),
ruleSet(const_cast<RuleSetSelectorPair*>(&rs)->ruleSet.release()) { }

I think the word “pair” would be better than “rs” for this variable name.

I think it’s awkward to write this as a copy constructor instead of a move
constructor.

Looks like you are just moving this code, though.


More information about the webkit-reviews mailing list