[webkit-reviews] review granted: [Bug 118621] [cairo] memory corruption with putImageData and accelerated canvas. : [Attachment 207356] updated patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Wed Aug 7 10:45:35 PDT 2013


Martin Robinson <mrobinson at webkit.org> has granted  review:
Bug 118621: [cairo] memory corruption with putImageData and accelerated canvas.
https://bugs.webkit.org/show_bug.cgi?id=118621

Attachment 207356: updated patch
https://bugs.webkit.org/attachment.cgi?id=207356&action=review

------- Additional Comments from Martin Robinson <mrobinson at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=207356&action=review


> Source/WebCore/platform/graphics/cairo/ImageBufferCairo.cpp:190
> +PassRefPtr<cairo_surface_t> mapSurfaceToImageAndAdjustRect(cairo_surface_t*
surface, IntRect& rect)

This should be renamed from map to copy since we are no longer trying to
replicate the Cairo map/ummap API.

> Source/WebCore/platform/graphics/cairo/ImageBufferCairo.cpp:240
> +	   copyRectFromOneSurfaceToAnother(data.m_surface.get(),
imageSurface.get(), IntSize(-area.x(), -area.y()), IntRect(IntPoint::zero(),
area.size()), IntSize(), CAIRO_OPERATOR_SOURCE);

You can just use IntPoint() here instead of IntPoint::zero()


More information about the webkit-reviews mailing list