[webkit-reviews] review granted: [Bug 115026] Improve the way UI element information is passed between AccessibilityMediaControls and the localization code : [Attachment 199332] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Apr 23 23:29:41 PDT 2013


Ryosuke Niwa <rniwa at webkit.org> has granted Benjamin Poulain
<benjamin at webkit.org>'s request for review:
Bug 115026: Improve the way UI element information is passed between
AccessibilityMediaControls and the localization code
https://bugs.webkit.org/show_bug.cgi?id=115026

Attachment 199332: Patch
https://bugs.webkit.org/attachment.cgi?id=199332&action=review

------- Additional Comments from Ryosuke Niwa <rniwa at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=199332&action=review


> Source/WebCore/platform/LocalizedStrings.h:241
> +    ENUM_CLASS(LocalizedMediaControlElement) {

I would call this MediaControlElementStringType or MediaControlElementString.
LocalizedMediaControlElement makes it sound as if this is an element.

> Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp:541
> +	   return String();

Can we ever reach here?

> Source/WebCore/platform/gtk/LocalizedStringsGtk.cpp:587
> +	   return String();

Ditto.

> Source/WebCore/platform/qt/LocalizedStringsQt.cpp:515
> +	   return String();

Ditto.

> Source/WebCore/platform/qt/LocalizedStringsQt.cpp:561
> +	   return String();

Ditto.


More information about the webkit-reviews mailing list