[webkit-reviews] review granted: [Bug 100049] [CSS Exclusions] Implement empty segments for multiple-segment shape-insides : [Attachment 198764] Updating patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Apr 19 10:50:13 PDT 2013


Dave Hyatt <hyatt at apple.com> has granted Bear Travis <betravis at adobe.com>'s
request for review:
Bug 100049: [CSS Exclusions] Implement empty segments for multiple-segment
shape-insides
https://bugs.webkit.org/show_bug.cgi?id=100049

Attachment 198764: Updating patch
https://bugs.webkit.org/attachment.cgi?id=198764&action=review

------- Additional Comments from Dave Hyatt <hyatt at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=198764&action=review


r=me, although see comment.

> Source/WebCore/rendering/RenderBlockLineLayout.cpp:1722
> +	   if (exclusionShapeInsideInfo && end == resolver.position()) {
> +	       float minWidth = firstPositiveWidth(wordMeasurements);
> +	       ASSERT(minWidth || wordMeasurements.isEmpty());
> +	       LayoutUnit nextLineHeight;
> +	       if (minWidth > 0 &&
exclusionShapeInsideInfo->adjustLogicalLineTop(minWidth))
> +		   nextLineHeight = exclusionShapeInsideInfo->logicalLineTop()
- absoluteLogicalTop;
> +	       else
> +		   nextLineHeight =
exclusionShapeInsideInfo->shapeLogicalBottom() - absoluteLogicalTop;
> +	       end = restartLayoutRunsAndFloatsInRange(logicalHeight(),
nextLineHeight, lastFloatFromPreviousLine, resolver, oldEnd);
>	       continue;

I think it would be nice to put this into a helper function, even if it's just
a static function that is up with firstPositiveWidth's definition.


More information about the webkit-reviews mailing list