[webkit-reviews] review granted: [Bug 97055] Reland "Add in-place reload behavior to ImagesEnabled setting" with optimizations : [Attachment 165236] Fix condition for whether to call load

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 24 10:10:12 PDT 2012


Adam Barth <abarth at webkit.org> has granted Bo Liu <boliu at chromium.org>'s
request for review:
Bug 97055: Reland "Add in-place reload behavior to ImagesEnabled setting" with
optimizations
https://bugs.webkit.org/show_bug.cgi?id=97055

Attachment 165236: Fix condition for whether to call load
https://bugs.webkit.org/attachment.cgi?id=165236&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=165236&action=review


This looks great.  Only one nit-picky comment below.

> Source/WebCore/loader/cache/CachedResourceLoader.h:129
> +    CachedResourceHandle<CachedResource>
requestResource(CachedResource::Type, ResourceRequest&, const String& charset,
const ResourceLoaderOptions&, ResourceLoadPriority =
ResourceLoadPriorityUnresolved, bool isPreload = false, bool
imageDeferredByClient = false);

Rather than add Boolean parameter, we prefer to add enum parameters, like
ResourceLoadPriority.  That makes things much easier to read at the call site. 
I realize that isPreload is already using a Boolean, but we might want to
convert that to a two-value enum in a followup patch.


More information about the webkit-reviews mailing list