[webkit-reviews] review granted: [Bug 96112] [chromium] Add a method didHandleGestureEvent to WebViewClient, called from WebViewImpl::handleGestureEvent. : [Attachment 164536] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 18 13:17:56 PDT 2012


Adam Barth <abarth at webkit.org> has granted Oli Lan <olilan at chromium.org>'s
request for review:
Bug 96112: [chromium] Add a method didHandleGestureEvent to WebViewClient,
called from WebViewImpl::handleGestureEvent.
https://bugs.webkit.org/show_bug.cgi?id=96112

Attachment 164536: Patch
https://bugs.webkit.org/attachment.cgi?id=164536&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=164536&action=review


>>> Source/WebKit/chromium/public/WebViewClient.h:146
>>> +	 virtual void didHandleGestureEvent(const WebGestureEvent& event, bool
handled) { }
>> 
>> The handled parameter here still seems a bit odd.  What does it mean for
didHandleGestureEvent to be called when handled is false?
> 
> This might just be a naming issue.  Would defaultWasPrevented be an
appropriate name?

Looking around in the code, "eventSwallowed" looks like it might be an
appropriate name.


More information about the webkit-reviews mailing list