[webkit-reviews] review granted: [Bug 96135] [chromium] WebImageSkia shouldn't use ImageSource : [Attachment 162887] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 17 11:06:06 PDT 2012


Adam Barth <abarth at webkit.org> has granted Hin-Chung Lam <hclam at google.com>'s
request for review:
Bug 96135: [chromium] WebImageSkia shouldn't use ImageSource
https://bugs.webkit.org/show_bug.cgi?id=96135

Attachment 162887: Patch
https://bugs.webkit.org/attachment.cgi?id=162887&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=162887&action=review


> Source/WebKit/chromium/src/WebImageSkia.cpp:55
> +    OwnPtr<ImageDecoder>
decoder(adoptPtr(ImageDecoder::create(*buffer.get(),
ImageSource::AlphaPremultiplied, ImageSource::GammaAndColorProfileApplied)));

ImageDecoder::create should call adoptPtr itself and return a PassOwnPtr.  You
don't need to fix that in this patch, but I just wanted to mention it.	(Also,
we tend to prefer the assignment form of the constructor for readability.

> Source/WebKit/chromium/src/WebImageSkia.cpp:87
> +    OwnPtr<NativeImageSkia> image = adoptPtr(frame->asNewNativeImage());

asNewNativeImage should probably also return a PassOwnPtr.


More information about the webkit-reviews mailing list