[webkit-reviews] review granted: [Bug 96114] [chromium] Make prioritized texture manager not touch backings array on the main thread : [Attachment 163272] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 10 21:43:07 PDT 2012


James Robinson <jamesr at chromium.org> has granted Christopher Cameron
<ccameron at chromium.org>'s request for review:
Bug 96114: [chromium] Make prioritized texture manager not touch backings array
on the main thread
https://bugs.webkit.org/show_bug.cgi?id=96114

Attachment 163272: Patch
https://bugs.webkit.org/attachment.cgi?id=163272&action=review

------- Additional Comments from James Robinson <jamesr at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=163272&action=review


This looks really nice to me.

I think one tradeoff to keep in mind in general with these classes is that they
seem to always end up being fairly deeply aware of our commit flow, our
threaded use of the class, or both.  I think being aware of the commit flow -
i.e. what things happen in what order from what threads - tends to be the least
intrusive of all of these.

>
Source/WebCore/platform/graphics/chromium/cc/CCPrioritizedTextureManager.cpp:39
7
> +	   if ((*it)->hadOwnerAtLastPriorityUpdate())

I think putting (*it) in an appropriately-named-and-typed temporary would be a
big readability win for this section


More information about the webkit-reviews mailing list