[webkit-reviews] review granted: [Bug 95883] Prevent overflows in FractionalLayoutUnit : [Attachment 162872] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Sep 7 15:03:26 PDT 2012


Eric Seidel <eric at webkit.org> has granted Emil A Eklund <eae at chromium.org>'s
request for review:
Bug 95883: Prevent overflows in FractionalLayoutUnit
https://bugs.webkit.org/show_bug.cgi?id=95883

Attachment 162872: Patch
https://bugs.webkit.org/attachment.cgi?id=162872&action=review

------- Additional Comments from Eric Seidel <eric at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=162872&action=review


> Source/WebCore/platform/FractionalLayoutUnit.h:249
> +    static const FractionalLayoutUnit safeMax()

I think we could come up with a better name than "safeMax".  Maybe "nearlyMax"
or "almostMax"?

> Source/WebCore/platform/graphics/FractionalLayoutRect.h:170
> +	   return FractionalLayoutRect(FractionalLayoutUnit::safeMin() / 2,
FractionalLayoutUnit::safeMin() / 2, FractionalLayoutUnit::safeMax(),
FractionalLayoutUnit::safeMax());

we should document here why this uses "safeMax", something like:

infiniteRect is slightly smaller than INT_MAX, INT_MAX, to allow pixelSnapping
to round up to the nearest value  w/o overflowing.


More information about the webkit-reviews mailing list