[webkit-reviews] review denied: [Bug 95536] Make compile with both OS(WINCE) and PLATFORM(QT) support : [Attachment 162447] Patch v2

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Sep 6 22:38:19 PDT 2012


Simon Hausmann <hausmann at webkit.org> has denied Kevin Funk
<kevin.funk at kdab.com>'s request for review:
Bug 95536: Make compile with both OS(WINCE) and PLATFORM(QT) support
https://bugs.webkit.org/show_bug.cgi?id=95536

Attachment 162447: Patch v2
https://bugs.webkit.org/attachment.cgi?id=162447&action=review

------- Additional Comments from Simon Hausmann <hausmann at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=162447&action=review


Nothing controversial, I'm glad to see that the patch is overall simple and
doesn't require a lot of changes. But there are a few things that should be
cleaned up IMO before this can go in.

> Source/WTF/WTF.pri:41
> +wince* {
> +    # for mt19937ar.c
> +    INCLUDEPATH += $${ROOT_WEBKIT_DIR}/Source/ThirdParty
> +}

Build flags are added to WTF.pri if they're needed for the build of WTF itself
_and_ other libraries using WTF. It seems that mt19937ar.c is only included
from wtf/RandomNumber.cpp and not anywhere outside of WTF. There I think that
this change should go into WTF.pro instead.

> Source/WebCore/WebCore.pri:234
> +win* {

I think this can be just written as win32, without the wild card.

> Source/WebCore/WebCore.pri:238
> +win32-* {

Would this perhaps be easier to read if it was written as win32:!wince* { ... ?


The current mix of win32, win32-* and win* is hard to read. It would be nice to
reduce the number of combinations :)

> Source/WebCore/WebCore.pri:259
> +    DEFINES += HAVE_LOCALTIME_S=0 ENABLE_JIT=0 ENABLE_FTPDIR=0

This is definitely the wrong place for ENABLE_JIT=0. Is it really needed here?
I don't see it being enabled for WINCE in wtf/Platform.h, but if it is, then
that would be the place to ensure that it's disabled.

I think HAVE_LOCALTIME_S can be removed entirely, I don't see any code in
WebKit actually using that define.

What's the reason for disabling the FTP directory parsing?


More information about the webkit-reviews mailing list