[webkit-reviews] review denied: [Bug 95614] Add support for blendmode to platform code for mac : [Attachment 161837] updated expectations file for chromium

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Sep 4 16:54:28 PDT 2012


Simon Fraser (smfr) <simon.fraser at apple.com> has denied Rik Cabanier
<cabanier at adobe.com>'s request for review:
Bug 95614: Add support for blendmode to platform code for mac
https://bugs.webkit.org/show_bug.cgi?id=95614

Attachment 161837: updated expectations file for chromium
https://bugs.webkit.org/attachment.cgi?id=161837&action=review

------- Additional Comments from Simon Fraser (smfr) <simon.fraser at apple.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=161837&action=review


> Source/WebCore/platform/graphics/ca/GraphicsLayerCA.cpp:1081
> +#if ENABLE(CSS_COMPOSITING)
> +    if (m_uncommittedChanges & CompositingChanged)
> +	   updateLayersCompositing();
> +#endif

I think it's very confusing to use the term "compositing" in code which is all
about accelerated compositing. Maybe use "blending" instead?

> Source/WebCore/platform/graphics/ca/GraphicsLayerCA.cpp:2782
> +void GraphicsLayerCA::updateLayersCompositing()

This should become updateBlending() or updateBlendMode(). The 'layer' in the
name is redundant.

> Source/WebCore/platform/graphics/ca/GraphicsLayerCA.h:383
> +	   CompositingChanged = 1 << 26,

blending.

> Source/WebCore/rendering/RenderLayerBacking.cpp:253
> +void RenderLayerBacking::updateLayerBlendMode(const RenderStyle* style)

'layer' here is redundant.


More information about the webkit-reviews mailing list