[webkit-reviews] review denied: [Bug 95672] [EFL][WK2] Add javascript popup api. : [Attachment 161938] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 3 18:52:11 PDT 2012


Gyuyoung Kim <gyuyoung.kim at samsung.com> has denied Byungwoo Lee
<bw80.lee at samsung.com>'s request for review:
Bug 95672: [EFL][WK2] Add javascript popup api.
https://bugs.webkit.org/show_bug.cgi?id=95672

Attachment 161938: Patch
https://bugs.webkit.org/attachment.cgi?id=161938&action=review

------- Additional Comments from Gyuyoung Kim <gyuyoung.kim at samsung.com>
View in context: https://bugs.webkit.org/attachment.cgi?id=161938&action=review


> Source/WebKit2/ChangeLog:8
> +	   Added ewk api for javascript alert(), confirm() and prompt().

s/api/API/g

> Source/WebKit2/UIProcess/API/efl/ewk_view.cpp:1594
> +void ewk_view_javascript_prompt_finished(Evas_Object*ewkView, const char*
result)

Missing a space in Evas_Object*ewkView.

> Source/WebKit2/UIProcess/API/efl/ewk_view.cpp:1599
> +    priv->javascriptPromptResult = adoptPtr(new CString(result ? result :
""));

Isn't this better ?

result ? adoptPtr(new CString(result)) : 0;

> Source/WebKit2/UIProcess/API/efl/ewk_view.h:243
> +	       char *message; /**< message for alert()*/

Missing a space in "alert()*/"

> Source/WebKit2/UIProcess/API/efl/ewk_view.h:246
> +	       char *message; /**< message for confirm()*/

ditto.

> Source/WebKit2/UIProcess/API/efl/ewk_view.h:249
> +	       char *message; /**< message for prompt()*/

ditto.

> Source/WebKit2/UIProcess/API/efl/ewk_view.h:250
> +	       char *default_value; /**< default value for prompt() input box*/


ditto.

> Source/WebKit2/UIProcess/API/efl/ewk_view_private.h:104
> +PassOwnPtr<CString> ewk_view_run_javascript_prompt(Evas_Object* ewkView,
char* message, char* default_value);

s/defalut_value/defaultValue/g

> Source/WebKit2/UIProcess/API/efl/ewk_view_ui_client.cpp:77
> +    return WKStringCreateWithUTF8CString(result ? result->data() : "");

I think this one is better. 

result ? adoptWK(WKStringCreateWithUTF8CString(result->data())) : 0;


More information about the webkit-reviews mailing list