[webkit-reviews] review granted: [Bug 95685] Move AllowShadowContent flag to HitTestRequest : [Attachment 161919] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Sep 3 07:14:52 PDT 2012


Antonio Gomes <tonikitoo at webkit.org> has granted Allan Sandfeld Jensen
<allan.jensen at nokia.com>'s request for review:
Bug 95685: Move AllowShadowContent flag to HitTestRequest
https://bugs.webkit.org/show_bug.cgi?id=95685

Attachment 161919: Patch
https://bugs.webkit.org/attachment.cgi?id=161919&action=review

------- Additional Comments from Antonio Gomes <tonikitoo at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=161919&action=review


r=me

please fix the method name before landing, and maybe strip out the supposedly
unrelated change?

> Source/WebCore/rendering/HitTestRequest.h:56
> +    bool allowShadowContent() const { return m_requestType &
AllowShadowContent; }

I think it should be allowsShadowContent

> Source/WebCore/rendering/HitTestResult.cpp:107
> -    , m_region(region)
> +    , m_region(region ? region : other.m_region)

unrelated

> Source/WebCore/rendering/HitTestResult.h:58
> -    HitTestLocation(const HitTestLocation&, const LayoutSize& offset,
RenderRegion*);
> +    HitTestLocation(const HitTestLocation&, const LayoutSize& offset,
RenderRegion* = 0);

unrelated?


More information about the webkit-reviews mailing list