[webkit-reviews] review granted: [Bug 100720] Build WebKit as C++11 on Mac : [Attachment 171359] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 29 22:19:48 PDT 2012


Daniel Bates <dbates at webkit.org> has granted Anders Carlsson
<andersca at apple.com>'s request for review:
Bug 100720: Build WebKit as C++11 on Mac
https://bugs.webkit.org/show_bug.cgi?id=100720

Attachment 171359: Patch
https://bugs.webkit.org/attachment.cgi?id=171359&action=review

------- Additional Comments from Daniel Bates <dbates at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=171359&action=review


> Source/WTF/ChangeLog:8
> +	   Additional information of the change such as approach, rationale.
Please add per-function descriptions below (OOPS!).

Please remove these sentences.

> Source/WTF/wtf/text/AtomicString.cpp:270
> +    UCharBuffer buffer = { s, static_cast<unsigned>(length) };

Would it make sense to change the static type of length from int to unsigned in
this function since, as its name implies, it's a length (so it should be
non-negative)? Then we don't need to explicitly cast it to unsigned here.

> Source/WebCore/platform/network/cf/FormDataStreamCFNet.cpp:467
> +    FormContext formContext = { formData.release(), static_cast<unsigned
long long>(length) };

Would it make sense to change the static type of length from long long to
unsigned long long in this function since, as its name implies, it's a length
(so it should be non-negative)? Then we don't need to explicitly cast it to
unsigned long long here.

> Tools/ChangeLog:8
> +	   Additional information of the change such as approach, rationale.
Please add per-function descriptions below (OOPS!).

Please remove these sentences.


More information about the webkit-reviews mailing list