[webkit-reviews] review granted: [Bug 99246] [TestResultServer] Move the resource loading into a dedicated class : [Attachment 169230] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Sat Oct 20 10:57:10 PDT 2012


Ojan Vafai <ojan at chromium.org> has granted Zan Dobersek
<zandobersek at gmail.com>'s request for review:
Bug 99246: [TestResultServer] Move the resource loading into a dedicated class
https://bugs.webkit.org/show_bug.cgi?id=99246

Attachment 169230: Patch
https://bugs.webkit.org/attachment.cgi?id=169230&action=review

------- Additional Comments from Ojan Vafai <ojan at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=169230&action=review


<3 this change so much. Thanks for doing this!

> Tools/TestResultServer/static-dashboards/dashboard_base.js:547
> +function resourceLoadingComplete()
>  {
> -    if(!haveJsonFilesLoaded())
> -	   return;
> +    g_resourceLoader = null;
> +    handleLocationChange();
> +}
>  
> +function handleLocationChange()
> +{
>      addBuilderLoadErrors();

I think this introduces a race-condition since we also call
handleLocationChange on the hashchange event. So, I think you might want
something like this at the beginning of handleLocationChange:
if (g_resourceLoader)
    return;


More information about the webkit-reviews mailing list