[webkit-reviews] review granted: [Bug 99731] Add 8-bit path to RenderBlock::handleTrailingSpaces() : [Attachment 169430] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 18 10:26:24 PDT 2012


mitz at webkit.org <mitz at webkit.org> has granted Michael Saboff
<msaboff at apple.com>'s request for review:
Bug 99731: Add 8-bit path to RenderBlock::handleTrailingSpaces()
https://bugs.webkit.org/show_bug.cgi?id=99731

Attachment 169430: Patch
https://bugs.webkit.org/attachment.cgi?id=169430&action=review

------- Additional Comments from mitz at webkit.org <mitz at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=169430&action=review


>>> Source/WebCore/rendering/RenderBlockLineLayout.cpp:1030
>>> +	     if (!isCollapsibleSpace(current, lastText))
>> 
>> Have you tried making current a CharacterType and making
isCollapsibleSpace() a function template as well?
> 
> In most cases I haven't done this.  The implicit conversion from an LChar
(unsigned char) to a UChar (unsigned short) is typically a nop.  If you think
it is more readable I can make that change.

If it doesn’t change the generated code, then no, I don’t think it’s necessary.


More information about the webkit-reviews mailing list