[webkit-reviews] review granted: [Bug 99273] in a column flexbox, input overflows the box when stretched : [Attachment 168972] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Tue Oct 16 11:08:14 PDT 2012


Ojan Vafai <ojan at chromium.org> has granted Tony Chang <tony at chromium.org>'s
request for review:
Bug 99273: in a column flexbox, input overflows the box when stretched
https://bugs.webkit.org/show_bug.cgi?id=99273

Attachment 168972: Patch
https://bugs.webkit.org/attachment.cgi?id=168972&action=review

------- Additional Comments from Ojan Vafai <ojan at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=168972&action=review


> Source/WebCore/rendering/RenderBox.cpp:1775
> +static bool flexboxChildHasStretchAlignment(const RenderObject* child)

Naming nit: how about flexItemHasStretchAlignment?

> Source/WebCore/rendering/RenderBox.cpp:1781
> +static bool isStretchingVerticalFlexboxChild(const RenderObject* child)

Naming nit: isStretchingColumnFlexItem

> Source/WebCore/rendering/RenderBox.cpp:1822
>	   if (!parent()->style()->isColumnFlexDirection() ||
parent()->style()->flexWrap() != FlexWrapNone)

If you added isFlexboxRowOrMultiline(parent), then you could use it here and in
isStretchingVerticalFlexboxChild. I think it would make the code a bit more
readable.


More information about the webkit-reviews mailing list