[webkit-reviews] review denied: [Bug 99116] [RequestAnimationFrame] Remove vendor prefix : [Attachment 168445] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Fri Oct 12 11:36:11 PDT 2012


Adam Barth <abarth at webkit.org> has denied James Simonsen
<simonjam at chromium.org>'s request for review:
Bug 99116: [RequestAnimationFrame] Remove vendor prefix
https://bugs.webkit.org/show_bug.cgi?id=99116

Attachment 168445: Patch
https://bugs.webkit.org/attachment.cgi?id=168445&action=review

------- Additional Comments from Adam Barth <abarth at webkit.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=168445&action=review


> Source/WebCore/page/DOMWindow.h:270
> +	   void webkitCancelAnimationFrame(int id) { cancelAnimationFrame(id);
}
> +	   void webkitCancelRequestAnimationFrame(int id) {
cancelAnimationFrame(id); }

You can just use ImplementedAs in the IDL rather than having these stub
functions here.

> Source/WebCore/page/DOMWindow.idl:216
> +    // W3C Web Performance WG Request Animation Frame standard.

I would skip this comment.  It's not adding any information.

> Source/WebCore/page/DOMWindow.idl:221
> +    long requestAnimationFrame(in [Callback] RequestAnimationFrameCallback
callback);
> +    void cancelAnimationFrame(in long id);
>      long webkitRequestAnimationFrame(in [Callback]
RequestAnimationFrameCallback callback);
>      void webkitCancelAnimationFrame(in long id);
>      void webkitCancelRequestAnimationFrame(in long id); // This is a
deprecated alias for webkitCancelAnimationFrame(). Remove this when removing
vendor prefix.

Please add V8MeasureAs attributes so that we can measure how often the prefixed
versions are used.  That way we'll know have more information about when we can
remove them.


More information about the webkit-reviews mailing list