[webkit-reviews] review denied: [Bug 95252] node search does not work with elements on touch start listener : [Attachment 168063] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Thu Oct 11 04:42:24 PDT 2012


Pavel Feldman <pfeldman at chromium.org> has denied Konrad Piascik
<kpiascik at rim.com>'s request for review:
Bug 95252: node search does not work with elements on touch start listener
https://bugs.webkit.org/show_bug.cgi?id=95252

Attachment 168063: Patch
https://bugs.webkit.org/attachment.cgi?id=168063&action=review

------- Additional Comments from Pavel Feldman <pfeldman at chromium.org>
View in context: https://bugs.webkit.org/attachment.cgi?id=168063&action=review


> Source/WebCore/inspector/InspectorInstrumentation.h:-111
> -    static void mouseDidMoveOverElement(Page*, const HitTestResult&,
unsigned modifierFlags);

New names are confusing. I would leave them as is and add new signal
"handleTouchEvent" instead.

> Source/WebCore/page/EventHandler.cpp:3771
> +    if (InspectorInstrumentation::platformEventHandled(m_frame->page()))

There is no need to generate two signals, I'd rather call
InspectorInstrumentation::handleTouchEvent and let inspector code handle it in
case of inspect element mode.


More information about the webkit-reviews mailing list