[webkit-reviews] review granted: [Bug 97948] flexbox does wrong baseline item alignment in columns : [Attachment 166555] Patch

bugzilla-daemon at webkit.org bugzilla-daemon at webkit.org
Mon Oct 1 15:42:10 PDT 2012


Ojan Vafai <ojan at chromium.org> has granted Tony Chang <tony at chromium.org>'s
request for review:
Bug 97948: flexbox does wrong baseline item alignment in columns
https://bugs.webkit.org/show_bug.cgi?id=97948

Attachment 166555: Patch
https://bugs.webkit.org/attachment.cgi?id=166555&action=review

------- Additional Comments from Ojan Vafai <ojan at chromium.org>
What if, instead of changing the logic of AlignBaseline, we made the chunk
before the switch statement pretend that we have a different alignment. That
would reduce some code duplication and more clearly match the spec text.

FlexAlign alignment = alignmentForChild(child);
if (alignment == AlignBaseline and hasOrthogonalFlow(child))
    alignment = (style()->flexWrap() == FlexWrapReverse) ? AlignFlexEnd :
AlignFlexStart;

Up to you. I find this logic easier to follow.


More information about the webkit-reviews mailing list