[webkit-reviews] review granted: [Bug 93646] Refactor V8 bindings to allow content scripts to access subframes : [Attachment 175963] Patch
bugzilla-daemon at webkit.org
bugzilla-daemon at webkit.org
Mon Nov 26 11:06:38 PST 2012
Adam Barth <abarth at webkit.org> has granted Dan Carney <dcarney at google.com>'s
request for review:
Bug 93646: Refactor V8 bindings to allow content scripts to access subframes
https://bugs.webkit.org/show_bug.cgi?id=93646
Attachment 175963: Patch
https://bugs.webkit.org/attachment.cgi?id=175963&action=review
------- Additional Comments from Adam Barth <abarth at webkit.org>
This patch is great and exactly how I'd hoped we'd be able to implement this
feature.
My only real comment is stylistic. I'd add a helper function align the lines
of
inline v8::Local<v8::Context>
ScriptController::contextForWorld(DOMWrapperWorld* world)
{
return v8::Local<v8::Context>::New(windowShell(world)->context());
}
since you use that idiom a bunch.
Once this rolls into Chromium, would you be willing to add extension API test
so we can test the integration with the extension system?
More information about the webkit-reviews
mailing list